No sale la imagen al publicar un link en el Muro de Facebook

Para dar las gracias debes entrar o registrarte en el foro

Mensajes: 4 Agradecido: 1
07 Feb 2013, 20:02# 1

Hola, intento publicar un link que tiene foto y texto de una página web en mi muro y hay veces que no me aparece la imagen de miniatura al lado del texto y solo me aparece el texto. No se que hacer, porque me gusta poner las entradas con su respectiva imagen. Empieza a cargar y es como si no la encontrara, otras veces me deja elegir entre varias imagenes, incluso a veces me deja elegir pero esa en concreto no está, que es la de cabecera, la más importante.... alguien sabe como solucionarlo, gracias!

Gracias  
Etiquetado en:
Mensajes: 679 Agradecido: 90
11 Feb 2013, 16:44# 2

Esto depende de la página o post que quieras publicar, si facebook no detecta la imagen la única solución es que el programador de la página ponga esta línea de código

Facebook Foros
Gracias  
Mensajes: 4 Agradecido: 1
28 Feb 2013, 18:29# 3

Muchas gracias iMoto!

La verdad es que lo intenté pero no me funcionó. Realmente creo que el problema es que una vez que no encuentra ninguna imagen (aunque las haya), luego hagas lo que hagas, no vuelve a cargar las imágenes, como que no las vuelve a buscar.

En cambio un solución válida es cambiar la URL, eso me funciona siempre, añades una letra y funciona..... que raro

Gracias  
Mensajes: 679 Agradecido: 90
01 Mar 2013, 22:28# 4

¿Quieres decir que facebook tiene una especie de "caché" y que no vuelve a comprobar si hay imagenes?

Facebook Foros
Gracias  
Mensajes: 4 Agradecido: 1
06 Mar 2013, 22:44# 5

Tenáis razón iMoto!! Sí que funcionaba el código que me dijiste, lo que pasa es que faltaba una cosa: LIMPIAR EL CACHÉ DE FACEBOOK, porque si no, no vuelve a buscar las imágenes aunque esté ese código.

Para ello hay que utilizar una web de desarrolladores de Facebook, una que depura la URL y entre otras cosas, te borra su caché y listo ;)

[cita]Y ahora otro truquillo asociado: a la que probéis este código, hagáis un cambio en la imagen y volváis a compartir la url, notaréis con sorpresa que Facebook seguirá mostrando la anterior imagen. Eso es debido a que el portal cachea las urls, lo cual no está mal para aumentar la velocidad de carga, pero podría producir más de un dolor de cabeza en algunos webmasters.

Solución: visitad la aplicación URL Linter de Facebook, tecleáis la url y la aplicación os mostrará toda la información sobre ella, a parte de borrar la caché y por lo pronto podréis volver a probar otra miniatura para la misma página.[/cita]

Gracias!! :D

Gracias  
1 persona ha dado las gracias: iMoto
Mensajes: 679 Agradecido: 90
06 Mar 2013, 23:08# 6

Me alegro de que haya funcionado, y gracias a ti por decirnos la solución!

Facebook Foros
Gracias  
Mensajes: 1 Agradecido: 0
19 Abr 2013, 14:54# 7

Buenas, he intentado hacer todo lo que dicen, pero no me aclaro. Tengo dos dudas. iMoto, cuando dices "si facebook no detecta la imagen la única solución es que el programador de la página ponga esta línea de código " a qué te refieres? ¿Dónde tengo que añadir image_src? Y la segunda pregunta es respecto a la limpieza del caché. Tengo claro que para hacerlo tengo que ir a este enlace http://developers.facebook.com/tools/debug Pero, ¿qué dirección debo meter ahí? la de mi facebook o la del enlace que quiero compartir y del cual no me sale la miniatura? Espero que podáis ayudarme. Un saludo y gracias!

Gracias  
Mensajes: 679 Agradecido: 90
20 Abr 2013, 14:42# 8

Hola, tienes que poner esa línea en el código fuente de la página y poner el link de la imagen.

Y la dirección que tienes que meter en debug es la de la página donde está la imagen, la del enlace que compartes

Facebook Foros
Gracias  

Publicidad

Patrocinadores